Am ersten Februar 2019 wurde das Release Dolibarr 9.0.0 auf Sourceforge veröffentlicht.

Ab Dolibarr 9 benötigt man mindestens PHP 5.5 und es wurde auch für PHP 7.3 freigegeben.